ETS2 - Iveco Evedys Bus V2.0 (1.39.x)

Euro Truck Simulator 2 Mods

Minimal required ETS2 version to get support is 1.39.x
Versions below 1.37 (included) are not supported at all.
Works under both DX11 and OpenGL. Does not appear in AI. Other variants (eg. 12m body) are not planned.

Credits:Etrusan


Similar Mods

ETS2 - BMW 320i E30 (1.35.X)
ETS2 - BMW 320i E30 (1.35.X)
2019-07-04 22:52:22 435
ETS2 - Volkswagen Golf 7 V2 (1.35.X)
ETS2 - Volkswagen Golf 7 V2 (1.35.X)
2019-07-05 18:05:20 431

Leave a comment


comment color Green comment color Silver comment color Blue comment color Black comment color Red comment color Yellow
Game Versions
Today Popular Mods
Latest Comments

Spintires - PPC (Tattoo Hurst-White Gearbox) V1.0 - irgaat say; " You are savior man thank you. " - (2020-11-24 10:51:32)

- Krxs say; " Yes, you have to buy the defmap file on https://roextended.ro " - (2020-11-24 08:04:22)

ETS2 - Scania S New Interior (1.39.x) - Papa Lutz say; " Mod does not work under 1.39 " - (2020-11-23 23:10:44)

- Luki38 say; " Brak pliku RX28defmap " - (2020-11-23 20:22:16)

ETS2 - All New Legacy Sky SR2 HD CIB Bus (1.39.x) - GIGATOM say; " kata sandi tidak terbuka " - (2020-11-23 16:46:12)

Back to Top